ji Version 5.0.1: Probleme mit neuer Reglerbedienung und Performance

  • Wenn ich jetzt eine falsche Stempelung rückgängig machen will (mit dem kleinen Schieberegler), dann lässt der sich nur noch schieben, während er früher mit Klicken quasi Stempel für Stempel rückgängig gemacht werden konnte. Auf Klicken reagiert der Schieberegler überhaupt nicht mehr.

  • Danke, da habe ich offenbar etwas übersehen. Aber: bisher bewegte der sich bei Klick um zwei Schritte!
    Tipp: Dieser Regler erhält beim Stempeln den Fokus, und man kann ihn dann direkt mit dem Mausrad bedienen, ohne die Maus bewegen zu müssen. Ein Mausradrasterschritt entspricht einem Reglerschritt.

  • Was für einen Rechner hast du?


    Mein PC hat einen i7-4770K 3,5 GHz mit Intel HD Graphics 4600. 4k-Filme auf Youtube zu spielen ist kein Problem.


    Ich habe mal ein verkleinertes Fenster unter dem Stil Obsidian getestet, und zwar mit dem Aufruf des Dialogs "Drucken-Vorschau", da dieser bei vollem Fenster 3,2 s benötigt. Ist das JI-Fenster auf 25% des Bildschirms (1/4 Bildschirm), sind es 3,1 s, liegt die Größe bei 6,25 %, so dauert es ebenfalls 3,1 s. Die Zeit wird offensichtlich nur durch das Dialog-Fenster bestimmt, das in allen Fällen dieselbe Größe hat.


    In einem anderen Test habe ich vom 25%-JI-Fenster mit einem Bild 3456 x 1999 px auf das 100%-Fenster umgeschaltet (Windows-Schaltfläche rechts oben): Dauer bis zum kompletten Fenster 1,2 s.


    Diesen Vorgang habe ich gefilmt und mit"Smart Cutter for DV und DVB" die Einzelbilder (Bildfolge 33 ms, genau 33,36 ms) analysiert. Die Zahlen entspechen der Anzeige in Smart Cutter in s.


    0.082 Mausklick (sichtbarer Ausschlag in Audio-Leiste).
    0.449 Der bisher sichtbare Desktopbereich ist schwarz abgedeckt.
    0.516 Die Größe des neuen Arbeitsmenüs wird erkennbar, alle Elemente sind noch voll sichtbar. Die Schieberleiste rechts vom Arbeitsbereich hat sich auf die gesamte Fensterhöhe ausgedehnt (sie ist beim Vollbild in UHD-Auflösung aber nie vorhanden). Die Bild-Infozeile ist mit ihren Einträgen jetzt doppelt sichtbar (beim kleinen Bild und für das noch nicht sichtbar große).
    0.550 Das alte Arbeitsmenü ist bis auf einige Elemente ausgegraut. Von der zuvor sichtbar gewordenen Bild-Infozeile ist nur noch "Exif-Daten:" sichtbar.
    0.583 Die ausgegrauten Elemente sind entfernt, die übrigen unverändert.
    0.616 Die Schieberleiste ist bis auf 2 Reststücke verschwunden, die bisher unveränderten Elemente sind es auch jetzt noch.
    0.650 Die ersten Elemente werden wieder hinzugefügt (an den selben Stellen wie die zuvor entfernten).
    0.716 Das Zufügen von Elementen stockt.
    1.017 Das bisherige kleine Bild ist entfernt, ebenso ein Teil der zuvor hinzugefügten Elemente. Die Bild-Infos sind wieder alle sichtbar.
    1.050 Es werden wieder Elemente hinzugefügt
    1.117...1,184 Es ist keine Veränderung erkennbar.
    1.217 Das Bild ist jetzt im gesamten JI-Fenster dargestellt. Es sind wieder einige Elemente hinzugefügt.
    1.284 Das Arbeitsmenü ist jetzt voll aufgebaut.


    Das Bild ist innerhalb einer Bildfolge (1.183 bis 1.217) mit 33 ms aufgebaut, wohl ähnlich schnell wie bei IrfanView, wo der gleiche Vorgang nicht stoppbar ist. Damit scheidet eine schwache Grafikleistung wohl aus.


    Das Zeitproblem bereitet offensichtlich der Menüaufbau. Vielleicht hilft die Zeitanalyse das Problem zu verringern, sinngemäß auch für andere Menüaubauzeiten. Die Filmdatei kann ich gerne zur Verfügung stellen.

  • Diese lange Zeiten (z.B. 3 Sekunden für den Drucken-Dialog) kann ich überhaupt nicht nachvollziehen, bei mir braucht das sowohl unter Win7 als auch unter Win10 weit weniger als eine Sekunde. Auch das Maximieren des Programmfensters dauert keine Sekunde.


    Wäre interessant Rückmeldungen auch von anderen Anwendern dazu zu bekommen. [icon='fa-exclamation',32][/icon]


    @pixelfan: Evtl. gibt es einen Zusammenhang mit der Desktop-Auflösung. Hast du schon mal eine geringere Auflösung ausprobiert?

  • Das Zeitproblem bereitet offensichtlich der Menüaufbau. Vielleicht hilft die Zeitanalyse das Problem zu verringern, sinngemäß auch für andere Menüaubauzeiten. Die Filmdatei kann ich gerne zur Verfügung stellen.

    Ich hatte Anfangs auch solche Performance Probleme. Dann erhielt ich den Hinweis bei „Bildschirmprofil berücksichtigen" keinen Haken zu setzen. Nachdem ich das rausgenommen hatte, war JI deutlich schneller.