jpg-Illuminator: Bugs und Verbesserungs-Vorschläge

  • Hallo,


    so ganz verstanden habe ich das noch nicht:


    > Ein neues Forum, das sich um JPG-Illuminator kümmern wird:


    Das klingt so als würde der Illu von digicamfotos zu digitalfototreff umziehen. Dazu wäre vielleicht mal eine offizielle Ansage sinnvoll, im 'alten' Forum steht dazu nämlich nichts. Ausserdem würden dann diverse Unterforen (wie im alten) gebraucht, dieses eine hier wird Ruck-Zuck vollaufen...


    Kleiner Bugreport: Wenn man ein Bild lädt, oder einfach nur das Programm startet, steht im Knopf der Automatik nicht 'A' sondern schon 'A1'. Das ist irreführend und verwirrend. Den Zustand 'nur A' kann ich überhaupt nicht erzeugen, er wäre aber immer dann richtig wenn ich noch gar nicht drauf geklickt habe, oder nachdem ich Reset angeklickt habe.


  • Ich denke dazu werden sich Bertram und Franz bei Gelegenheit äussern.



    Quote


    Ausserdem würden dann diverse Unterforen (wie im alten) gebraucht, dieses eine hier wird Ruck-Zuck vollaufen...


    Naja, Unterforen hat es bei digicamfotos auch keine. Nur Sammelthreads. Diese stellen aber kein Problem dar und können jederzeit angelegt werden.






    Patrick

  • Samedate :

    Quote

    so ganz verstanden habe ich das noch nicht


    ... wir auch noch nicht wirklich.
    Wie du siehst, ist etliches im Umbruch. Wir werden jedenfalls momentan in beiden Foren präsent sein. Spätestens mit dem nächsten Update des ji wollen wir auch hier entsprechende Threads starten.

    Quote

    Automatik-Button 'A' oder 'A1'


    'A1' zeigt an, dass du die erste Automatik-Routine aufrufen kannst, 'A2' ruft die zweite auf. Wäre es besser, die Bezeichnungen 'A' und 'A2' zu wählen, und anschließend dann 'A1' ??? Das wäre doch auch verwirrend.
    Viele Grüße
    Bertram

  • Für mich sollte der Button den aktuellen Zustand anzeigen. Also nach Start oder Reset einfach nur A. Steht da A1 drauf ist die erste Version geladen, klicke ich erneut wechselt er zu A2, die zweite ist geladen, klicke ich erneut sollte wieder A erscheinen und der Automatikmodus aus sein (!). Das wäre IMHO sowhl intuitiv als auch selbsterklärend. Und besser als derzeit, weil man den A-Modus nur über das grosse Reset ausschalten kann, und damit viele weitere inzwischen vorgenommene Einstellungen auch verliert.


    Hmm, dieses Forum hat schon mal einen grossen Vorteil: ich werde automatisch angemeldet. Das hat im anderen nie geklappt. :)

  • Quote from "Samedate"

    Für mich sollte der Button den aktuellen Zustand anzeigen. Also nach Start oder Reset einfach nur A. Steht da A1 drauf ist die erste Version geladen, klicke ich erneut wechselt er zu A2, die zweite ist geladen, klicke ich erneut sollte wieder A erscheinen und der Automatikmodus aus sein (!).


    Vollste Zustimmung :thumbup::thumbup: Wenn das umzusetzen wäre... Toll :danke:

    EBV :daumenhoch:


    Sony α7II - SEL2870 - SEL24240

    LA-EA3 - SAL70300G SSM - Tamron 90mm USD Makro

  • Den Vorschlag zur Auto-Taste finden wir gut! Wir sind halt bisher davon ausgegangen, dass ein Button die Aktion anzeigt, die er auslöst. Andererseits spricht hier eigentlich wenig dagegen, dass er den aktuellen Zustand (A1, A2) wiedergibt. Und die Möglichkeit, zum Zustand vor Betätigung der Automatik (A) zurückzukehren, ist sicher manchmal hilfreich.

  • Super, die 430 funzt gut!


    Hier eine Frage an die Experten. Habe mir eine Canon S95 gegönnt. Die zeigt bei der Wiedergabe der Bilder optional mittels bis zu mehrerer Rahmen im Bild die Bereiche die für die Fokussierung benutzt wurden. Schöne Info! Nun musste ich mit Erstaunen feststellen, dass die mitgelieferte Software (die ich weder benutze noch benutzen will) diese Fokussierbereiche auch anzeigen kann. Scheinbar ist die Info dazu in den Exif-Daten enthalten?


    Weiss da einer genaueres? Wenn der Illu das auch könnte wäre es ein cooles Feature und auch Alleinstellungsmerkmal. Mir ist kein anderes Programm bekannt (XnView, IrfanView, Corel, ACDC, Fast Stone...) welches das kann...aber vielleicht habe ich ja auch was verpasst....

  • Quote from "Samedate"

    Mir ist kein anderes Programm bekannt (XnView, IrfanView, Corel, ACDC, Fast Stone...) welches das kann...aber vielleicht habe ich ja auch was verpasst....


    PhototME kann das - es sollte also irgendwo in den EXIF Daten "versteckt" sein...

    EBV :daumenhoch:


    Sony α7II - SEL2870 - SEL24240

    LA-EA3 - SAL70300G SSM - Tamron 90mm USD Makro

    Edited once, last by HoSt ().

  • Quote

    Samedate hat geschrieben:
    Mir ist kein anderes Programm bekannt (XnView, IrfanView, Corel, ACDC, Fast Stone...) welches das kann...aber vielleicht habe ich ja auch was verpasst....


    Die NX-Versionen von Nikon können das auch, allerdings muß man ein Objektiv mit CPU vor der Kamera gehabt haben, um diesen Effekt nutzen zu können. Auch sollten die Bilder vor der Bearbeitung damit überprüft werden, da sonst die Anzeige alles mögliche vorgaukelt, nur nicht den ursprünglichen Bereich der Fokussierung.

    "Es kann von keinem vernünftigen Menschen jeden Tag was Gescheites kommen." Hans Meyer

  • Quote from "Samedate"

    Die [S95] zeigt bei der Wiedergabe der Bilder optional mittels bis zu mehrerer Rahmen im Bild die Bereiche die für die Fokussierung benutzt wurden. Schöne Info! Nun musste ich mit Erstaunen feststellen, dass die mitgelieferte Software (die ich weder benutze noch benutzen will) diese Fokussierbereiche auch anzeigen kann. Scheinbar ist die Info dazu in den Exif-Daten enthalten?


    Ja, das wird in den Exif-Daten gespeichert, allerdings nicht im Standard-Bereich sondern in den Hersteller-abhängigen Daten. Das heißt die Infos sind für verschiedene Kameramodelle unterschiedlich gespeichert. In ji werten wir nur standardisierte Exif-Daten aus, weil es einfach zu viele Hersteller und Modelle gibt. Überdies legen die Hersteller die Struktur ihrer eigenen Exif-Daten meist nicht offen.

  • Damit gebe ich meinen Segen diesen Vorschlag wieder zu begraben, denn das wird ein Fass ohne Boden...


    Und um Franz' Worte zu bestätigen: aus den Bildern der S95 kann PhotoMe keine AE oder AF-Punkte/-Bereiche erkennen. Da wäre wohl ein Update nötig...

  • @betram:


    Sicher kann man in vielen Fällen die Entstehung von Tonwertabrissen vermindern oder in Grenzen kaschieren, wirklich verhindern wirst du sie bei vollen Bearbeitungsmöglichkeiten aber wohl nur, wen ihr dem JpegIlluminator noch eine Unterstützung für Tiff und 16Bit spendiert (Raw-Entwicklung können ja andere Tools übernehmen).

  • Flash : klasse Bearbeitung!


    Quote from "Flash"

    bertram :
    Sicher kann man in vielen Fällen die Entstehung von Tonwertabrissen vermindern oder in Grenzen kaschieren, wirklich verhindern wirst du sie bei vollen Bearbeitungsmöglichkeiten aber wohl nur, wenn ihr dem jpg-Illuminator noch eine Unterstützung für Tiff und 16Bit spendiert (Raw-Entwicklung können ja andere Tools übernehmen).


    Das ist richtig...
    Zunächst ist ji angetreten, den Abstand zwischen Jpeg und RAW mit durchdachten Algorithmen zu verringern. Das ist uns auch überraschend gut gelungen. Insofern ist es folgerichtig, auch an der Verminderung von Tonwertabrissen, die bei heftiger Bearbeitung entstehen, zu arbeiten. Den ersten Schritt dazu haben wir ja von Anfang an eingebaut: die Berechnung aller Reglerstellungen in einem Schritt mit Gleitpunktgenauigkeit. Am zweiten Schritt sind wir dabei: entstehende Abrisse zu kaschieren.
    ...und das hast du schön gesagt: :)
    "Tiff spendieren" hört sich sehr einfach an und wir würden es sofort anpacken, wenn es für uns nicht so unendlich viel Aufwand bedeuten würde. Wir müssten das Programm von Grund auf neu konzipieren. Und einem Bild, welches im jpeg-Format vorliegt, würde das überhaupt nichts nützen.